Le mini panier est mis en cache et contient déjà un produit

Problème

Lorsqu'un visiteur se rend sur votre site pour la première fois, le mini panier semble être mis en cache et contient déjà un ou plusieurs articles. La visite de la page du panier elle-même montre qu'il n'y a pas d'articles dans le panier, mais le widget ne se met pas à jour.

Cause

Les problèmes de panier peuvent être liés à l'optimisation par WP Rocket de la requête get_refreshed_fragments de WooCommerce.

Solution

Installez cette extension d'aide sur votre site pour désactiver cette fonction :

📥  Télécharger (.zip):  WP Rocket | Deactivate WooCommerce Refresh Cart Fragments Cache
Développeurs : vous pouvez trouver le code de cette extension sur GitHub.

  1. Téléchargez le fichier zip de l'extension d'aide 
  2. Installez l'extension d'aide sur votre site - allez à Extensions → Ajouter → Téléverser une extension et sélectionnez le fichier zip. 
  3. Activez l'extension

Si cette solution ne fonctionne pas, le problème pourrait être différent, lié à la manière dont est codé le widget de panier sur votre site. Veuillez consulter ce guide pour plus de détails.

Cela a-t-il répondu à votre question ? Merci pour votre retour :) Une erreur est survenue lors de l’envoi de votre retour. Veuillez réessayer plus tard.